Authentication issues

Incident Report for Stenoa

Resolved

The incident is now resolved and all services are fully operational.
Posted Jun 12, 2025 - 21:17 UTC

Identified

An incident with our authentication provider is resulting in degraded service for some users. Users who are not logged in may have issues signing in. Users who are logged in should not be affected. No data was lost or compromised from this incident.
Posted Jun 12, 2025 - 18:26 UTC
This incident affected: Mobile Applications (iOS, Android) and Web Application.