This incident has been resolved by our authentication provider. The issue caused a partial outage lasting 25 minutes affecting some users trying to access the Stenoa web and mobile applications. No data was lost or compromised. We continue to monitor the situation.
Posted Mar 20, 2026 - 10:45 UTC
Identified
The issue has been identified with our authentication provider, and they are working on a fix. Some users may experience issues accessing the application.
Posted Mar 20, 2026 - 10:19 UTC
Update
We are continuing to investigate this issue.
Posted Mar 20, 2026 - 10:12 UTC
Investigating
We have detected an unusual number of API errors and are investigating the cause.
Posted Mar 20, 2026 - 10:01 UTC
This incident affected: Mobile Applications (iOS, Android) and Web Application.